Belkin f5d7630 adsl modem settings for PTCL

I have an issue with belkin f5d7630 adsl modem I need the configuration for ptcl connection if any one could help me plz post the setting for this modem I am trying hard but the internet is not working in this modem
thanks in advance

Here are the screen shots of the modem i have read your guide & made the settings but still it isnt working kindly look at these & tell me what should I do.

Is your connection using a copper wire or fiber?

The only mistake I could spot is your secondary DNS which you have entered as which is wrong. It should be instead.
Your PTCL is lying to you. Please check if you are even able to ping the IP

The correct IP addresses for Google DNS are listed here.

Correct IP is

This argument can rest for the moment as this is not the problem as having a wrong secondary DNS won't interfere in connecting.
right secondary DNS is optional I changed the value to but the problem is still the same ..any how any other suggestions ?
No, you don't need to enter IP as it is assigned by the ISP. It's dynamic IP not static.

Can you check if the ADSL light is on or not? By the looks of it, you don't have an ADSL link on your line. It would help if you called up PTCL to check everything is fine on their end of the line.


Staff member
I dont see any mistakes in the screenshots apart from the secondary DNS.

Can you try changing the "connect type" from the current auto to always on and see if that helps.

Also check you have adsl link light on or not.
The DSL is quite fine as I am using it right now with my old TP link modem provided by PTCL I have called the PTCL today they dont think this modem is right is use on ADSL so far I understand they dont have deep technical consultancy availble .& I have changed the connection type to always connected ..but there is no improvement ..This modem has become a challange for me guys
Is this model f5d7630 viable in Pakistan region I think there could be regional conflict that might cause the problem .I tried to contact BELKIN there was some indian guy for assistance who after hearing I am from Pakistan said I should call Belkin india for help


Staff member
I have run out of ideas. I have seen your settings in screenshots and I dont have a clue why it wont work. Try contacting Belkin support and see what they say.
I succeed some how in establishing the connection but the problem is still there could browse internet here is the security log I am posting if any one could point out where I am wrong
08/01/2003 00:12:38 Can't find NTP time.
08/01/2003 00:12:17 If(PPPoE1) PPP connection ok !
08/01/2003 00:12:16 PPPoE1 get IP:
08/01/2003 00:12:16 Username and Password: OK
08/01/2003 00:12:15 PPPoE1 start PPP
08/01/2003 00:12:15 PPPoE receive PADS
08/01/2003 00:12:15 PPPoE send PADR
08/01/2003 00:12:15 PPPoE receive PADO
08/01/2003 00:12:15 PPPoE send PADI
08/01/2003 00:12:10 PPPoE send PADI
08/01/2003 00:12:05 PPPoE send PADI
08/01/2003 00:12:05 ADSL Media Up !
08/01/2003 00:11:46 PPPoE stop
08/01/2003 00:11:46 PPPoE1 stop PPP
08/01/2003 00:11:46 ADSL Media Down !
08/01/2003 00:11:38 Can't find NTP time.
08/01/2003 00:11:34 If(PPPoE1) PPP connection ok !
08/01/2003 00:11:33 PPPoE1 get IP:
08/01/2003 00:11:33 Username and Password: OK
08/01/2003 00:11:33 PPPoE1 start PPP
08/01/2003 00:11:33 PPPoE receive PADS
08/01/2003 00:11:33 PPPoE send PADR
08/01/2003 00:11:33 PPPoE receive PADO
08/01/2003 00:11:33 PPPoE send PADI
08/01/2003 00:11:28 sending ACK to
08/01/2003 00:11:28 PPPoE send PADI
08/01/2003 00:11:28 ADSL Media Up !
08/01/2003 00:11:28 sending OFFER to
08/01/2003 00:11:24 sending OFFER to
08/01/2003 00:11:22 sending OFFER to
08/01/2003 00:11:14 sending OFFER to
08/01/2003 00:11:04 PPPoE stop
08/01/2003 00:11:04 PPPoE1 stop PPP
08/01/2003 00:11:04 ADSL Media Down !
08/01/2003 00:10:58 If(PPPoE1) PPP connection ok !
08/01/2003 00:10:57 PPPoE1 get IP:
08/01/2003 00:10:57 Username and Password: OK
08/01/2003 00:10:57 PPPoE1 start PPP